CCIE知识点总结——三层技术

1、EIGRP
(1)复习
<1>Packet types:hello、query、update、ack、reply
Hello:发现、建立和维护邻居关系
Update:传递路由更新信息
Ack:确认
Query:丢失某一条路由且没有备份路径时,向所有邻居发出查询
Reply:响应query
<2>Route types:internal、external、summary:90 170 5
<3>Multicast:224.0.0.10
<4>AD、FD、FC、successor、feasible successor
AD:下一跳设备到达目的网络的距离
FD:本身到达目的网络的距离
Successor:到达目的网络最优下一跳
FS:符合FC条件的备份下一跳
FC:AD小于FDmin 作用:防环
<5>metric度量
K值 K1=K3=1 K2=K4=K5=0 K6=0
Metric=带宽+延迟
带宽=107Kbit/带宽(沿途路由入接口或数据出接口的带宽最小值)Kbit*256
延迟=沿途路由入接口或数据出接口的延迟总和us/10us*256
<6>Stub
Connected
Summary
Receive-only
Redistribute
Static
<7>Stuck in active
A—-B—-C
A丢失某一条路由,发出query报文给B,B还有邻居C,向邻居发出query,邻居C回应reply给B,B回复reply给A
如果C收到查询后不给B reply,B无法回复reply给A,A启动16次重传,导致A—-B之间的邻居关系重置
SIA-reply:当收到query,查询完本地数据库后可直接回复SIA-reply
<8>Graceful shutdown
妥善关闭,当接口从EIGRP网络中移除时,从该接口中发出goodbye消息,对端直接中断邻居关系,加快网络收敛
<9>Equal-cost、unequal-cost
不等价负载均衡,通过调整variance值将FS加入进传递数据的队伍
FS的metric/Success的metric 向上取整
<10>Summary
Ip summary-address eigrp as号 x.x.x.x x.x.x.x

(2)单播指邻居

(3)Leak-map:泄露部分子网路由
Example 1: eigrp stub leak-map Command
Router(config)# router eigrp 1
Router(config-router)# eigrp stub leak-map route-map

Example 2: ip summary-address eigrp
Router(config)# interface Serial 0/0
Router(config-if)# ip summary-address eigrp 1 10.0.0.0 255.0.0.0 leak-map route-map1

(4)address-family
EIGRP Autonomous-System Configuration
address-family ipv4 [unicast] vrf vrf-name [autonomous-system autonomous-system-number]
EIGRP Named IPv4 Configuration
address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number
EIGRP Named IPv6 Configuration
address-family ipv6 [unicast] [vrf vrf-name] autonomous-system autonomous-system-number
configures an IPv4 address-family session for the VRF named RED
Router(config)# ip vrf RED
Router(config-vrf)# rd 1:1
Router(config-vrf)# exit
Router(config)# router eigrp 1
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# autonomous-system 101
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)#default-metric 10000 100 255 1 1500
Router(config-router-af)# exit-address-family

configures a non-VRF address-family
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 3
Router(config-router-af)# network 10.0.0.0 0.0.0.255

configures a non-VRF address-family
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv6 autonomous-system 3
Router(config-router-af)# network 2001:1::/64

2、OSPF
(1)复习
<1>Packet types
Hello:发现、建立和维护邻居关系
DBD:链路状态数据库描述报文,选举主从/LSA的头部信息
LSR:请求报文,索要LSA
LSU:给LSA
LS Ack:确认
<2>Neighbor relationship
Down
Attempt:NBMA网络中出现
Init:交互hello报文
必要条件:1)hello时间,2)area ID, 3)认证,4)特殊区域标识
2-way:选举DR和BDR
DR和BDR选举规则:
0)谁先启动谁是DR
1)优先级 默认为1 ,0表示弃权,越大越优
2)router-id 越大越优
router-id的选举规则:
1)手动指定
2)活跃的环回口中IP地址最大的
3)活跃的物理接口中IP地址最大的
exstart:交互DBD的第一组报文,选举主从,以主设备的序列号开始同步DBD报文
I:初始化,第一个DBD报文此位 置1
M:更多,后续如果还有更多DBD报文则此位 置 1
MS:master,主设备此位 置1
主从选举规则:router-id越大越优
exchange:交互剩余的DBD
loading:交互LSR和LSU,发送ACK
full:
<3>LSA types(1,2,3,4,5,7,8,9)
产生者,作用,通告范围
1:all,直连接口的链路信息,本区域
2:DR,MA网络的掩码,本区域
3:ABR,1、2的汇总信息,AS
4:ASBR区域的ABR,描述ASBR的位置,AS
5:ASBR,外部路由,AS
7:NSSA区域的ASBR,外部路由,NSSA区域
8:IPv6中的1类的作用
9:IPv6中的2类的作用
<4>Route types
O、O IA、OE 1、OE 2、ON 1、ON 2
<5>Network types
P2P
P2MP
BMA
NBMA
P2MP NB
LOOPBACK 不管环回口的掩码是多少位,传递出去后全都是/32
<6>area types:backbone、nomal、stub、NSSA
末梢:过滤4、5类LSA,自动下发3类默认路由,不允许引入外部路由
完全末梢:过滤3、4、5类LSA,自动下发3类默认路由,不允许引入外部路由
非完全完全末梢NSSA:过滤4、5类LSA,不会自动下发默认路由,需要使用default-information-originate下发7类默认路由,允许引入外部路由
完全非完全完全末梢:过滤3、4、5类LSA,自动下发3类默认路由,允许引入外部路由
router types:internal router、ABR、ASBR
<7>Virtual-link
一条属于area 0的逻辑线路
<8>Authentication
空认证
明文认证
MD5消息摘要认证
接口下认证
区域认证
(2)Graceful Shutdown
OSPF Graceful Shutdown 特性能够让关闭OSPF的影响降到最小,并且通知OSPF邻居OSPF进程即将关闭,所有具有其它路径的流量将被引入到其它路径,该特性能够关闭OSPF路由器上的某个接口,关闭OSPF某个接口后,OSPF不再通告该接口信息。即在不丢失配置的情况下临时性关闭OSPF进程。
配置
Router(config)# router ospf 1
Router(config-router)#shutdown


Router(config)# interface Ethernet0/0
Router(config-if)# ip ospf shutdown

(3)Max-metric
通告最大的metric使得其他设备在计算SPF时不会优选该设备
配置
max-metric router-lsa [external-lsa [max-metric-value]] [include-stub] [inter-area-lsas [max-metric-value]] [on-startup {seconds | wait-for-bgp}] [prefix-lsa] [stub-prefix-lsa [max-metric-value]] [summary-lsa[max-metric-value]]
3、BGP
(1)BGP状态

4、路径控制工具
(1)ACL
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.1.0

access-list 1 permit 192.168.1.0 0.0.254.255 192.168.0.0中的奇数路由
access-list 1 permit 192.168.0.0 0.0.254.255 192.168.0.0中的偶数路由

小标签增删
Router#show ip access-lists
Standard IP access list 1
10 permit 192.168.1.1
20 permit 192.168.1.2
30 permit 192.168.1.3
40 permit 192.168.1.4
Router(config)#ip access-list standard 1
Router(config-std-nacl)#no 10
Router(config-std-nacl)# 5 permit 192.168.1.0
Router#show ip access-lists
Standard IP access list 1
5 permit 192.168.1.0
20 permit 192.168.1.2
30 permit 192.168.1.3
40 permit 192.168.1.4

(2)Offset-list
Offset-list用于在距离矢量路由协议中增大metric,可在in和out两个方向使用,使用acl匹配目标路由,如不书写acl则表示匹配所有,不指定接口表示对所有接口有效。
配置
access-list 1 permit 192.168.1.0
offset-list acl编号 out/in 增大的值 接口

Permit的会增加metric,Deny的不增加metric。
(3)Distribute-list
用于控制路由更新加表,在距离矢量路由协议中in和out都有效,且会影响下游邻居,在链路状态路由协议中只有in方向有效,但对下游邻居不影响,out方向无效,除非是本地始发的外部路由。
配置
distribute-list acl编号/前缀列表/route-map out/in 接口
Permit的通告,Deny的不通告。
(4)Redistribute
RIP和EIGRP默认种子度量值为0,表示无穷大,需设置参数。
OSPF默认只携带主类路由,需要使用subnets支持子网路由传递。
5、IPv6
(1)NDP:邻居发现协议
使用ICMPv6报文实现以下功能:
<1>地址解析(相当于IPv4的ARP)
<2>跟踪邻居的状态
<3>重复地址检测(Duplicate Address Detect, DAD)
<4>无状态地址自动配置
<5>前缀重新编址
<6>重定向
地址解析使用两种ICMPv6报文:邻居请求(Neighbor Solicitation, NS) 、邻居通告(Neighbor Advertisement, NA)。这两种报文只有在以太网链路才有,在HDLC、PPP链路是没有的。

DAD重复地址检测
新配置了一个接口地址或者一个接口由shutdown—>no shutdown,经过DAD的过程,地址才能配置生效。DAD没有完成之前,地址处于Tentative(实验)状态。

因为该地址未生效,所以A发送NS报文时,Src=::(未指定地址),目的地址为自己想要查找IPv6地址转换的请求节点地址。如果1秒钟后没有检测到冲突,就发送non-solicited advertisement。
新配置了一个接口地址或者一个接口由shutdown—>no shutdown,经过DAD的过程,地址才能配置生效。DAD没有完成之前,地址处于Tentative(实验)状态。
(2)SLAAC:Stateless Address Autoconfiguration
IPv6的标准功能,无需进行手工配置:即插即用性,减轻网络管理的负担。对主机、路由器均可进行自动配置,可配置多个地址进行网络无缝迁移。
报文种类
RS:Router solicitaion,由主机主动发出(加快地址配置速度,RA缺省每200s周期发送) ,回应报文为RA报文,源地址为发送者link-local地址,目的地址为FF02::2。
RA:Router Advertisement,由路由器发出 ,收到RS后发出或周期性自动发出,源地址为发送者Link-local地址,目的地址为FF02::1或发送RS的主机单播地址。
串口下,缺省是不发送RA消息,配置no ipv6 nd ra suppress 才发送。
这两种报文都基于ICMPv6报文。

(3)DHCPv6
客户端首先检测链路上的路由器的存在,如果找到,则检查路由器通告,以确定是否可以使用DHCP,如果没有路由器发现,则发送DHCP请求消息到所有DHCP的代理多播地址,使用链路本地地址作为源地址。
使用以下组播地址:
FF02::1:2 = All DHCP Agents (servers or relays, Link-local scope)
FF05::1:3 = All DHCP Servers (Site-local scope)
DHCP消息:客户端侦听UDP端口546;服务器和中继代理监听UDP端口547。

前缀推送

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 书香水墨 设计师:CSDN官方博客 返回首页